2,021 bytes added
, 16:21, 13 May 2016
m'''Major INFO! TAKE ALWAYS the GENERIC FILE of the LAST RELEASE !! Cause much Changes done here!'''
Current:
1. Make Backup of the System Disk (dd diskdump)
2. Use a copy of the current updated GENERIC Kernel config File !!
3. If you want to upgrade to 9.0 use GENERIC-File of FreeBSD 9.0 !!! path /usr/src/sys/i386/conf/GENERIC make a copy named "custom" and edit it to modify)
4. Download the current sources of the Base System wget ftp://ftp.freebsd.org/pub/FreeBSD/releases/i386/9.0-RELEASE/src.txz
5. Extract it to /usr/src with
<pre>
tar -C / -xvzf src.txz
</pre>
6. cp GENERIC to custom
<pre>
cp /usr/src/sys/i386/conf/GENERIC /usr/src/sys/i386/conf/custom
</pre>
7. Edit custom and change desciption GENERIC to custom, delete lines of unwanted modules, save and exit custom
8. Rebuild world with:
<pre>
cd /usr/src
make -s buildworld
</pre>
9. Build Custom Kernel
<pre>
make -s buildkernel KERNCONF=custom
</pre>
10. Install Custom Kernel
<pre>
make -s installkernel
</pre>
11. Reboot to Single Mode or Remote via SSH disable most uneeded services at /etc/rc.conf with "#", but not SSH !!!
12. Install World
<pre>
mergemaster -p
make -s installworld
mergemaster -i
</pre>
13. enable services at /etc/rc.conf remove "#" and Reboot the FreeBSD Server
14. TEST THE SYSTEM + DO SECURITY CHECKS! (sockstat -4 / -6 = open Ports)
<hr>
Old:
<pre>
- insert Freebsd i386 CD (netinstall)
- Boot Server from CD
- select keyboard for your Country
- select Custom Expert Install at Install Mananger "sysinstall"
- make a "minimal" setup
- reboot
- login as root
- start $sysinstall
- select distributions
- select src
- select base+tools+sys
- install sources from ftp.freebsd.org
exit sysinstall mananger
- as root go $cd /usr/src/sys/i386/conf
download "custom" Kernelfile from here
- copy into custom into /usr/src/sys/i386/conf
- run as root:
$/usr/sbin/config custom
$cd ..compile/custom
$make cleandepend
$make depend
$make
$make install
$make clean
</pre>
[[KERNEL-FILE-CONFIG]]